Stability of the API with its changes has been confirmed. Issue is officially resolved. - Lain
Posted May 30, 2026 - 03:38 UTC
Monitoring
EDUrocks has identified the cause of the the downtime and fixed it. Code with a memory leak inside of our staging environment was accidentally pushed onto the production server causing the database for EDUrocks to go down. We have now fixed that and pushed changes to the API to make it handle better under situations. Sorry to any affected EDUrocks users, we are now monitoring the API uptime and will close out this Incident whenever it can be confirmed the API will stay up. - Lain
Posted May 29, 2026 - 08:14 UTC
Investigating
EDUrocks has been alerted of the API being down causing a disruption in user experience for Accounts, AI, Live Chat, and Movies.
Posted May 29, 2026 - 07:27 UTC
This incident affected: Site Services (EDUrocks API V2).